Derniers Articles
Vous êtes ici : Accueil / Tutoriaux / Développement / Windev Mobile : Créer une application android avec système login

Windev Mobile : Créer une application android avec système login

Un de nos participants débutant sur les produits PcSoft me demande comment mettre en place un système de login sur une application Mobile.

Voici la solution la plus simple :

//INITIALISATION DU PROJET

PUBLIC
gfbMotPasseOK     est un booléen = Faux          // Indique si le mot de passe est correct ou non
gfnEssaiSaisi     est un entier = 3          // Nombre d’essai 3

///////////////////////////////////////////////////////

//BOUTON VALIDER du login

//LOGIN OU UTILISATEUR à partir du fichier login

Fichier login dans lequel vous inscrivez les informations utilisateurs.

// SAI_LOGIN EST UNE COMBO RELIÉE AU FICHIER LOGIN

//MOT DE PASSE EN DUR

SI SAI_LOGIN= »NOM PRENOM » ALORS
motpasse= »MotDePasseAssocie »
FIN

// Sinon utilise la méthode rechercher le mot de passe dans le fichier avec cryptage et décryptage à la lecture pour la comparaison
// si sansespace(sai_passe)=sansespace(login.motdepasse)

SI Sai_Passe=motpasse ALORS    // SAI_PASSE EST LE CHAMP DE SAISIE DU MOT DE PASSE

OuvreFenêtreMobile(Fen_Menu)

SINON

Erreur(« Le mot de passe saisi est incorrect »)

// Décrémenter le nombre d’essai
gfnEssaiSaisi–

SI gfnEssaiSaisi = 0 ALORS
gfbMotPasseOK = Faux
Ferme()
FIN

RepriseSaisie(Sai_Passe)

FIN

Répondre

Votre adresse email ne sera pas publiée.

shared on wplocker.com